Project

General

Profile

Bug #705

0.4.2 crash on startup systray icon click.

Added by jotik over 12 years ago. Updated over 12 years ago.

Status:
Rejected
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
05/25/2009
Due date:
% Done:

0%

Estimated time:
Version:
0.5-pre
OS:
Linux

Description

Steps to reproduce:
1) Start Quassel client
2) Wait for it to connect
3) Click tray icon to show main window -> crash

I'm using Quassel 0.4.2 on Gentoo Linux with Qt 4.5.1 (both server and client, but on different machines).

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f381bbd5760 (LWP 4932)]
QSortFilterProxyModel::parent (this=0x119fc30, child=@0x1687220) at itemviews/qsortfilterproxymodel.cpp:152
152 Q_ASSERT(it.value());
(gdb) bt
#0 QSortFilterProxyModel::parent (this=0x119fc30, child=@0x1687220) at itemviews/qsortfilterproxymodel.cpp:152
#1 0x00007f381aec4a71 in QTreeView::indexRowSizeHint (this=0x1189390, index=@0x1687220) at src/corelib/kernel/qabstractitemmodel.h:369
#2 0x00007f381aec51db in QTreeViewPrivate::itemHeight (this=0x16d1150, item=0) at itemviews/qtreeview.cpp:3205
#3 0x00007f381aec5481 in QTreeViewPrivate::updateScrollBars (this=0x16d1150) at itemviews/qtreeview.cpp:3457
#4 0x00007f381aec58bf in QTreeView::updateGeometries (this=0x1189390) at itemviews/qtreeview.cpp:2691
#5 0x00007f381a9f576c in QWidget::event (this=0x1189390, event=0x7fff23c14da0) at kernel/qwidget.cpp:7667
#6 0x00007f381ad72cdb in QFrame::event (this=0x1189390, e=0x7fff23c14da0) at widgets/qframe.cpp:559
#7 0x00007f381ae9375d in QAbstractItemView::viewportEvent (this=0x1189390, event=0x7fff23c14da0) at itemviews/qabstractitemview.cpp:1471
#8 0x00007f381aecde22 in QTreeView::viewportEvent (this=0x1189390, event=0x7fff23c14da0) at itemviews/qtreeview.cpp:1264
#9 0x00007f381b71c3c7 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x11a5210, event=0x7fff23c14da0)
at kernel/qcoreapplication.cpp:726
#10 0x00007f381a9a235c in QApplicationPrivate::notify_helper (this=0x1036460, receiver=0x11a5210, e=0x7fff23c14da0) at kernel/qapplication.cpp:4053
#11 0x00007f381a9aafae in QApplication::notify (this=0x7fff23c184b0, receiver=0x11a5210, e=0x7fff23c14da0) at kernel/qapplication.cpp:4022
#12 0x00007f3818b7505b in KApplication::notify (this=0x7fff23c184b0, receiver=0x11a5210, event=0x7fff23c14da0)
at /usr/src/debug/kde-base/kdelibs-4.2.3/kdelibs-4.2.3/kdeui/kernel/kapplication.cpp:307
#13 0x00007f381b71c92b in QCoreApplication::notifyInternal (this=0x7fff23c184b0, receiver=0x11a5210, event=0x7fff23c14da0) at kernel/qcoreapplication.cpp:606
#14 0x00007f381a9f02c9 in QWidgetPrivate::sendPendingMoveAndResizeEvents (this=0x116c660, recursive=false, disableUpdates=false)
at src/corelib/kernel/qcoreapplication.h:213
#15 0x00007f381a9f63c3 in QWidgetPrivate::show_helper (this=0x0) at kernel/qwidget.cpp:6669
---Type <return> to continue, or q <return> to quit---
#16 0x00007f381a9f6a6a in QWidget::setVisible (this=0x11a5210, visible=<value optimized out>) at kernel/qwidget.cpp:6947
#17 0x00007f381a9f685e in QWidgetPrivate::showChildren (this=<value optimized out>, spontaneous=false) at src/gui/kernel/qwidget.h:473
#18 0x00007f381a9f63df in QWidgetPrivate::show_helper (this=0x16d1150) at kernel/qwidget.cpp:6675
#19 0x00007f381a9f6842 in QWidgetPrivate::showChildren (this=<value optimized out>, spontaneous=false) at kernel/qwidget.cpp:7033
#20 0x00007f381a9f63df in QWidgetPrivate::show_helper (this=0x1182f50) at kernel/qwidget.cpp:6675
#21 0x00007f381a9f6842 in QWidgetPrivate::showChildren (this=<value optimized out>, spontaneous=false) at kernel/qwidget.cpp:7033
#22 0x00007f381a9f63df in QWidgetPrivate::show_helper (this=0x11004a0) at kernel/qwidget.cpp:6675
#23 0x00007f381a9f6a6a in QWidget::setVisible (this=0x1100360, visible=<value optimized out>) at kernel/qwidget.cpp:6947
#24 0x00007f3818bf3142 in KSystemTrayIcon::minimizeRestore (this=0x11da050, restore=true) at /usr/include/qt4/QtGui/qwidget.h:473
#25 0x00007f3818bf32a5 in KSystemTrayIcon::activateOrHide (this=0x11da050, reasonCalled=<value optimized out>)
at /usr/src/debug/kde-base/kdelibs-4.2.3/kdelibs-4.2.3/kdeui/util/ksystemtrayicon.cpp:289
#26 0x00007f3818bf412e in KSystemTrayIcon::qt_metacall (this=0x11da050, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff23c154e0)
at /usr/src/debug/kde-base/kdelibs-4.2.3/kdelibs_build/kdeui/ksystemtrayicon.moc:84
#27 0x00007f381b724cf2 in QMetaMethod::invoke (this=0x7fff23c159b0, object=0x11da050, connectionType=Qt::DirectConnection, returnValue= {<QGenericArgument> = {_data = 0x0, _name = 0x0}, <No data fields>}, val0= {_data = 0x7fff23c15b6c, _name = 0x5c54a8 "QSystemTrayIcon::ActivationReason"}, val1={_data = 0x0, _name = 0x0}, val2={_data = 0x0, _name = 0x0}, val3= {_data = 0x0, _name = 0x0}, val4={_data = 0x0, _name = 0x0}, val5={_data = 0x0, _name = 0x0}, val6={_data = 0x0, _name = 0x0}, val7= {_data = 0x0, _name = 0x0}, val8={_data = 0x0, _name = 0x0}, val9={_data = 0x0, _name = 0x0}) at kernel/qmetaobject.cpp:1522
#28 0x00007f381b7253f4 in QMetaObject::invokeMethod (obj=0x11da050, member=<value optimized out>, type=Qt::AutoConnection, ret=
---Type <return> to continue, or q <return> to quit--- {<QGenericArgument> = {_data = 0x0, _name = 0x0}, <No data fields>}, val0= {_data = 0x7fff23c15b6c, _name = 0x5c54a8 "QSystemTrayIcon::ActivationReason"}, val1={_data = 0x0, _name = 0x0}, val2={_data = 0x0, _name = 0x0}, val3= {_data = 0x0, _name = 0x0}, val4={_data = 0x0, _name = 0x0}, val5={_data = 0x0, _name = 0x0}, val6={_data = 0x0, _name = 0x0}, val7= {_data = 0x0, name = 0x0}, val8={_data = 0x0, _name = 0x0}, val9={_data = 0x0, _name = 0x0}) at kernel/qmetaobject.cpp:1114
#29 0x000000000044947d in SystemTray::on_activated (this=0x11a0b80, reason=QSystemTrayIcon::Trigger) at /usr/include/qt4/QtCore/qobjectdefs.h:403
#30 0x00000000004b6c9e in SystemTray::qt_metacall (this=0x11a0b80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff23c15cb0)
at /usr/src/debug/net-irc/quassel-0.4.2/quassel-0.4.2_build/src/qtui/moc_systemtray.cxx:104
#31 0x00007f381b7322d5 in QMetaObject::activate (sender=0x11da050, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x0)
at kernel/qobject.cpp:3108
#32 0x00007f381afbc7ce in QSystemTrayIcon::activated (this=0x0, _t1=QSystemTrayIcon::Trigger) at .moc/debug-shared/moc_qsystemtrayicon.cpp:128
#33 0x00007f381afb0e5c in QSystemTrayIconSys::mousePressEvent (this=0x1176480, ev=0x7fff23c165a0) at util/qsystemtrayicon_x11.cpp:298
#34 0x00007f381a9f5abb in QWidget::event (this=0x1176480, event=0x7fff23c165a0) at kernel/qwidget.cpp:7517
#35 0x00007f381a9a238d in QApplicationPrivate::notify_helper (this=0x1036460, receiver=0x1176480, e=0x7fff23c165a0) at kernel/qapplication.cpp:4057
#36 0x00007f381a9ab7d4 in QApplication::notify (this=<value optimized out>, receiver=0x1176480, e=0x7fff23c165a0) at kernel/qapplication.cpp:3759
#37 0x00007f3818b7505b in KApplication::notify (this=0x7fff23c184b0, receiver=0x1176480, event=0x7fff23c165a0)
at /usr/src/debug/kde-base/kdelibs-4.2.3/kdelibs-4.2.3/kdeui/kernel/kapplication.cpp:307
#38 0x00007f381b71c92b in QCoreApplication::notifyInternal (this=0x7fff23c184b0, receiver=0x1176480, event=0x7fff23c165a0) at kernel/qcoreapplication.cpp:606
#39 0x00007f381a9aa932 in QApplicationPrivate::sendMouseEvent (receiver=0x1176480, event=0x7fff23c165a0, alienWidget=0x0, nativeWidget=0x1176480,
buttonDown=<value optimized out>, lastMouseReceiver=@0x7f381b379030) at src/corelib/kernel/qcoreapplication.h:216
---Type <return> to continue, or q <return> to quit---
#40 0x00007f381aa0c28c in QETWidget::translateMouseEvent (this=0x1176480, event=<value optimized out>) at kernel/qapplication_x11.cpp:4448
#41 0x00007f381aa0ad65 in QApplication::x11ProcessEvent (this=0x7fff23c184b0, event=0x7fff23c17fa0) at kernel/qapplication_x11.cpp:3566
#42 0x00007f381aa30ca4 in x11EventSourceDispatch (s=0x1039ad0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#43 0x00007f3816acc711 in IA
_g_main_context_dispatch (context=0x1038d20) at gmain.c:2144
#44 0x00007f3816acfe8d in g_main_context_iterate (context=0x1038d20, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2778
#45 0x00007f3816ad004b in IA__g_main_context_iteration (context=0x1038d20, may_block=1) at gmain.c:2841
#46 0x00007f381b744aff in QEventDispatcherGlib::processEvents (this=0x1022460, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:324
#47 0x00007f381aa304ff in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#48 0x00007f381b71b592 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 599884432}) at kernel/qeventloop.cpp:149
#49 0x00007f381b71b725 in QEventLoop::exec (this=0x7fff23c182d0, flags={i = 599884512}) at kernel/qeventloop.cpp:196
#50 0x00007f381b7203ee in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#51 0x000000000042f595 in main (argc=1, argv=0x7fff23c18878) at /usr/src/debug/net-irc/quassel-0.4.2/quassel-0.4.2/src/common/main.cpp:134


Related issues

Is duplicate of Quassel IRC - Bug #663: Crash when disabling uniform row heights for BufferViewAssigned2009-04-07

History

#1 Updated by Sputnick over 12 years ago

  • Status changed from New to Rejected

Good ol'e model crash...

Also available in: Atom PDF