Project

General

Profile

Bug #398

It doesn't minimize.

Added by chiiph about 14 years ago. Updated about 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Quassel GUI (Qt)
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Version:
0.3.1+
OS:
Any

Description

I'm running Gentoo Linux, with Quassel 0.3.0.3 and KDE 4.1.72.
I have Quassel in system tray with no problems, but when I try to minimize it to the taskbar, it disappears from it and appears again maximize but out of focus. I've try to minimize every way I know but it's all the same.
This doesn't happen with any other application, in case you think it's because of my unstable KDE version.

Associated revisions

Revision 366f5e33 (diff)
Added by Marcus Eggenberger about 14 years ago

This could / should / oh well you know the drill... just test if minimize to tray now works properly (BR #398)

History

#1 Updated by nightrose about 14 years ago

I have the same problem.
It is because of having "minimize to tray" and "close to tray" being enabled. If I only enable "close to tray" it works fine.

#2 Updated by Sputnick about 14 years ago

I can't reproduce this with a current git version, so I consider this fixed in git.

#3 Updated by kitterma about 14 years ago

I can reproduce this with a git snapshot from today if minimize to tray on minimize button is set. If I uncheck that, it goes away.

#4 Updated by kitterma about 14 years ago

[22:53:42] <Daisuke_Ido> i just built with git and can't reproduce it
[22:54:08] <ScottK> Daisuke_Ido: I also have KDE integration on. Dunno if that could matter.
[22:54:13] ScottK tries again.
[22:54:36] <ScottK> Yep.
[22:54:58] <ScottK> Check off minimize to try on minimize button and it bounces right back up.
[22:55:20] <ScottK> If I click on the icon it's fine.
[22:55:35] <Daisuke_Ido> the kde integration could matter, since i don't use kde at all
[22:55:47]
Daisuke_Ido pokes Sput
[22:59:46] <ScottK> Daisuke_Ido: minimize to tray on close button does not cause the problem for me. Just minimize to tray on minimize.
[23:02:22] <Daisuke_Ido> ScottK: is kitterma you?
[23:03:00] <Daisuke_Ido> ScottK: i tried with both, and had no issues. i'm thinking it might involve the kde integration

#5 Updated by Gentle about 14 years ago

confirmed with current git version and kde integration enabled. Minimize to tray results in instant unminimizing, while close to tray works

#6 Updated by Sputnick about 14 years ago

  • Status changed from Resolved to Feedback
  • Priority changed from High to Normal
  • Target version changed from 0.3.1 to 0.4.0

I'm reopening this, as there have been reports that it still doesn't work for some people. I cannot reproduce this even with KDE integration though, so we'll need someone to debug that for me...

#7 Updated by Gentle about 14 years ago

<freeedrich|> Sput: the problem happens when you have quassel set to "minimize to tray on close". So, on KDE's shutdown it probably receives a "Quit" event, but instead of quitting it tells kde "nope, I want to go to the tray again" and cancels the Shutdown/Restart process that way.

#8 Updated by EgS about 14 years ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Sputnick to EgS

Also available in: Atom PDF