Project

General

Profile

Bug #1235

Crash on add network with "freenode" preset

Added by penis about 8 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Quassel GUI (KDE)
Target version:
-
Start date:
07/30/2013
Due date:
% Done:

0%

Estimated time:
Version:
0.9-pre
OS:
Linux

Description

I did the following:
- start quassel
- setup wizard starts, I do the pages up to the one that wants to add ubuntu server
- I click cancel then
- I go to network configuration
- I try to add the 'freenode' preset and it segfaults (everytime)

- I then started quassel and did the wizard again but this time I finished it, including adding the ubuntu server
- I deleted the server
- I tried to add the 'freenode' preset again and it worked (no segfault)
Quassel-Crash-20130731-1836.log (5.93 KB) Quassel-Crash-20130731-1836.log quasselclient backtrace Anonymous, 07/31/2013 06:43 PM

History

#1 Updated by Anonymous about 8 years ago

Would you happen to have the crash logs (should be in the configdir, ~/.config/quassel-irc.org if run as your user; /var/lib/quassel if the core crashed and you used the initscripts)?

Also, such an appropriate username.

#2 Updated by Anonymous about 8 years ago

  • Status changed from New to Feedback

#3 Updated by Anonymous about 8 years ago

Client crashes when adding a network to an unconfigured core. Looks like lack of identity makes it do that, so probably should disable the menu until the wizard is finished. Perhaps the wizard should not be cancellable without disconnecting from the core (mono makes that nasty), saving settings when the page is finished is also nasty. Reworking the network page from the wizard seems viable (either list the presets or make the name writable).

#4 Updated by phuzion 4 months ago

This bug is likely fixed with the resolution of #1409 and this PR. https://github.com/quassel/quassel/pull/549

#5 Updated by digitalcircuit 4 months ago

  • Status changed from Confirmed to Resolved

As remarked by phuzion, this should be fixed in the upcoming 0.14 release (including 0.14rc1 release candidate, out now).

Also available in: Atom PDF