Project

General

Profile

Bug #1020

Wrong nickname when connecting to bouncer

Added by X-2 about 11 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
09/08/2010
Due date:
% Done:

100%

Estimated time:
Version:
0.7.2
OS:
Any

Description

My situation is like this:

I have a bouncer. Whenever I disconnect from it, my nickname automatically gets changed to 'Xaer0|g0ne'.
If I connect back to the bouncer, my nickname gets changed back to my main nickname 'Xaer0'.

Quassel shows my correct nickname in the nicklist, however it doesn't for messages.

example
[11:50:41] <***> Playback Complete.
[11:50:45] <Xaer0|g0ne> hi

I've also added a screenshot.

quassel-1.png (125 KB) quassel-1.png X-2, 09/08/2010 12:15 PM
bnc.patch (700 Bytes) bnc.patch TorrentialStorm, 06/18/2011 06:49 PM

Related issues

Related to Quassel IRC - Bug #964: Nick Select Doesn't Update on Forced Nick ChangeNew2010-05-15

Has duplicate Quassel IRC - Bug #1209: Quassel displaying wrong nicknames when connected to bouncerClosed2013-03-28

Associated revisions

Revision 77611288 (diff)
Added by MBasaglia over 7 years ago

Use correct nick on 001 RPL_WELCOME

Fixes #1020
When the user connects to a bouncer, the bouncer will send back the
welcome message received when it first connected to the network.
This caused Quassel to display a wrong nick if it had changed
since the first connection.

Revision 3b8318c1 (diff)
Added by MBasaglia about 7 years ago

Use correct nick on 001 RPL_WELCOME

Fixes #1020
When the user connects to a bouncer, the bouncer will send back the
welcome message received when it first connected to the network.
This caused Quassel to display a wrong nick if it had changed
since the first connection.

History

#1 Updated by TorrentialStorm over 10 years ago

Same issue here. It's coming from when the bouncer reconnects and has to use an alternate nick. The bouncer sends the original RPL_WELCOME it got when connecting (which would be the alt nick).

:moo.us.p2p-network.net 001 TorrentialStorm :Welcome to the P2P-NET IRC Network TorrentialStorm_!~

#2 Updated by TorrentialStorm over 10 years ago

I've managed to fix this in 0.7.2. See attached patch.

#3 Updated by johu over 10 years ago

  • Version changed from 0.6.2 to 0.7.2
  • OS changed from Linux to Any

There is a handler for 001, maybe the following lines are redundant:

if (cmd == "001") {
  network()->setMyNick(_target);
}

Please verify your patch.

#4 Updated by TorrentialStorm over 10 years ago

The handler uses the nick from the welcome message, not the target.

:moo.us.p2p-network.net 001 TorrentialStorm :Welcome to the P2P-NET IRC Network TorrentialStorm_!~
target would be the current nick. one in the welcome message is the alt nick.

#5 Updated by xeross about 10 years ago

I think this might be caused by the same bug as #964

#6 Updated by TorrentialStorm about 10 years ago

It's not a forced nick change issue. It's due to the bouncer sending the original RPL_WELCOME (which has the alternate nick). My patch fixes both issues, it takes the nick from the target for RPL_WELCOME and I updated it to accept forced nick changes.

#7 Updated by xeross about 10 years ago

I'm compiling a patched version now, will report back if the issue still appears or not.

#8 Updated by xeross about 10 years ago

This does indeed seem to work, thanks :)

#9 Updated by xeross about 10 years ago

Only thing that doesn't always seem to update is the nick selector, I'll try and see if I can patch that up.

#10 Updated by rbrent almost 10 years ago

I just tested TorrentialStorm's patch against 0.7.3 -- it works great! Thanks. :)

It can't hurt to make this part of the normal builds, can it?

#11 Updated by dennis97519 over 8 years ago

Umm...How do I use the patch?

#12 Updated by Anonymous over 8 years ago

Grab quassel's source, apply the patch using either `git patch bnc.patch` or `patch -Np1 <bnc.patch` whilst in the quassel directory. Then compile as usual.

#13 Updated by MBasaglia over 7 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset quassel|commit:77611288238aef3777466f5d647dd2780f5f72d1.

Also available in: Atom PDF