Project

General

Profile

Bug #625

editline jumps funny

Added by xAFFE almost 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Quassel GUI (KDE)
Target version:
Start date:
03/14/2009
Due date:
% Done:

100%

Estimated time:
Version:
0.3.0.x
OS:
Any

Description

When I'm tiping a message, the editline jumps strangly. I have attached a vid of this.

I'm using quassel-git and kde 4.2

Associated revisions

Revision 0f94681b (diff)
Added by Manuel Nickschas almost 12 years ago

Various tweaks to the input line in KDE mode

  • Resize correctly according to font size, fixes #625
  • Handle Ctrl+F correctly, thanks to Jesper Thomsch├╝tz for input

Revision b59ac9ea (diff)
Added by Manuel Nickschas almost 12 years ago

Consider frameWidth() for setting the inputline height

Turns out that the problem of being too large if we do this seems to be an
issue with a new documentMargin() property in Qt 4.5. Setting this to 0 and
adding the frameWidth() to the font height should fix #625.

History

#1 Updated by jesperht almost 12 years ago

In src/uisupport/inputline.cpp, if you change:

setMaximumHeight(document()->size().toSize().height());

to

setMaximumHeight(document()->size().toSize().height()+2);

It works according to xAFFE (couldn't reproduce it on my system).

#3 Updated by Sputnick almost 12 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#4 Updated by xAFFE almost 12 years ago

In Changeset 0f94681b05463c64c75d25d18a0ab2fd1d4af7b9 the attached Patch is not included.

Please reopen this issue!

#5 Updated by xAFFE almost 12 years ago

  • Status changed from Resolved to Feedback

Reopened this issue.

Thanks EgS

#6 Updated by EgS almost 12 years ago

  • Status changed from Feedback to Assigned
  • Assignee set to Sputnick

#7 Updated by Sputnick almost 12 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 0.5.0
  • Version changed from 0.4.0+ to 0.3.0.x

#8 Updated by xAFFE almost 12 years ago

Sputnick wrote:

Fixed properly now in http://git.quassel-irc.org/?p=quassel.git;a=commit;h=b59ac9eaf6ab7580bca7d2cde3849229ddd11483 one would hope.

yup, can confirm this one.

Also available in: Atom PDF