Project

General

Profile

Bug #510

Channel traffic fed into network buffer too

Added by kitterma almost 14 years ago. Updated almost 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Quassel Client
Target version:
Start date:
02/02/2009
Due date:
02/16/2009
% Done:

100%

Estimated time:
Version:
0.3.1+
OS:
Any

Description

With the current Kubuntu package, we default to freednode (called Kubuntu IRC) and #kubuntu. Traffic for #kubuntu also shows up in the network buffer too. It looks almost like they are symlinked as if I click on one, they both unhighlight for no pending traffic. Also it doesn't matter if I move where it is on the list.

I only see this in the mono client, but my buffer list in the split client predates the package provided list.

I'm not sure if this is my patch or some other issue. Patch attached.

kubuntu_01_default_network_channel.patch (638 Bytes) kubuntu_01_default_network_channel.patch kitterma, 02/02/2009 12:54 PM
_kubuntu.png (273 KB) _kubuntu.png EgS, 02/02/2009 01:55 PM
Kubuntu_IRC.png (285 KB) Kubuntu_IRC.png EgS, 02/02/2009 01:55 PM
snapshot1.png (246 KB) snapshot1.png After traffic in #kubuntu kitterma, 02/02/2009 03:10 PM
snapshot2.png (245 KB) snapshot2.png Clicked on #kubuntu (note network in no longer hilighted either) kitterma, 02/02/2009 03:10 PM
snapshot3.png (245 KB) snapshot3.png Clicked on Kubuntu IRC kitterma, 02/02/2009 03:10 PM
snapshot4.png (274 KB) snapshot4.png kitterma, 02/02/2009 11:54 PM

Associated revisions

Revision 74b71a1d (diff)
Added by Marcus Eggenberger almost 14 years ago

Fixes #510 - Network item shows wrong buffer

History

#1 Updated by EgS almost 14 years ago

I was unable to reproduce this.

Applied your patch and tested it with a clean config. Only thing I did after starting the mono client was rightclicking on "Kubuntu IRC" and selected connect.

Attached two screenshots.

#2 Updated by EgS almost 14 years ago

Are you sure it's not the chatmonitor? Some screenshots could be helpful

#3 Updated by kitterma almost 14 years ago

Here's some screenshots ..

#4 Updated by EgS almost 14 years ago

To be honest: I don't see what's wrong with those screenshots (despite the fact that snapshot2.png and snapshot3.png look the very same).

I don't think you mean the "[ChanServ] Welcome to #Kubuntu!..." message, do you?

#5 Updated by kitterma almost 14 years ago

The issue is that the same content is in the "Kubuntu IRC" and #kubuntu buffers. Maybe it's some setting corruption issue. Let me delete the local data and try again.

#7 Updated by EgS almost 14 years ago

  • Due date set to 02/16/2009
  • Category set to Quassel Client
  • Status changed from New to Assigned
  • Assignee set to EgS
  • Target version set to 0.4.0

#8 Updated by EgS almost 14 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF