Project

General

Profile

Feature #386

Expand input box when multiple lines are pasted

Added by hagabaka over 12 years ago. Updated over 11 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Quassel GUI (Qt)
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
OS:
Any

Description

When pasting multiple lines to the input box, all the lines are sent to the channel immediately. This sometimes leads to unintended flooding. It is also unexpected because if a single line without line break is pasted, it would not be sent until the user presses Enter. It would be nice to have the input box expand to show the multiple lines so they can be edited, as well as an indication that multiple lines are about to be sent if the user presses Enter.


Related issues

Related to Quassel IRC - Feature #443: Tab completion should show list of possible matchesAssigned

Related to Quassel IRC - Feature #373: Please add paste control with pastebinNew

Related to Quassel IRC - Bug #541: Preliminary Paste Control per DialogResolved2009-02-112009-02-16

Is duplicate of Quassel IRC - Feature #213: Add a multiline write line with a toogle button like ChatzillaResolved

Associated revisions

Revision f047a4f7 (diff)
Added by Manuel Nickschas over 11 years ago

Introduce multi-line editing for the inputline

This introduces the new MultiLineEdit that basically enhances the old InputLine widget by being
able to expand to show more than one line. All non-editing related things have been moved out of the
MultiLineEdit to ease reuse in other widgets. For example, InputWidget-specific keypresses are now handled
in InputWidget rather than MultiLineEdit.

Closes #209, closes #213, fixes #386. Thanks to Squider for input (I saw your patch too late, but I did refactor
things anyway...)

History

#1 Updated by Sputnick about 12 years ago

Mhm, we'll see about finding a way to make this work within our UI. Feedback as of how something like that could look like more than welcome. Note that simply replacing the inputline by a textedit won't probably work for us; maybe we want a popup instead?

#2 Updated by Sputnick about 12 years ago

  • Status changed from New to Assigned
  • Assignee set to Sputnick
  • Priority changed from High to Normal
  • Target version set to 0.4.0
  • OS set to Any

Should add at least add a warning messagebox as a temporary solution for 0.4. Something more elaborate for a later version then.

#3 Updated by EgS about 12 years ago

  • Target version deleted (0.4.0)

#4 Updated by DevUrandom almost 12 years ago

Related to #209.

#5 Updated by Sputnick over 11 years ago

  • Status changed from Assigned to Rejected

Also available in: Atom PDF