Project

General

Profile

Feature #369

Please implement "onotice" (chanop-only notices) support

Added by TerrorBite almost 12 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Quassel Core
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
OS:

Description

Some IRCds have support for PRIVMSGs and NOTICEs sent only to channel operators. These are known as omsg/onotices, and some clients have /omsg and /onotice commands to send them.
Notices are sent as follows:

NOTICE @#channel :Foo

and are recieved only by channel operators as follows:

:nick!user@host NOTICE @#channel :Foo

Privmsgs are similar to this.
On IRCds with extended prefix support, sending messages to only admins/owners may also be possible.

Also, can someone please implement the /notice command? Or at least include a default alias for it.


Related issues

Has duplicate Quassel IRC - Feature #348: A command for sending notices should be providedResolved

Associated revisions

Revision 5cb19c84 (diff)
Added by Marcus Eggenberger almost 12 years ago

Fixing BR #369 (handle onotice/omsg properly, add /notice command)

History

#1 Updated by EgS almost 12 years ago

Fixed in current git.
http://git.quassel-irc.org/?p=quassel.git;a=commit;h=5cb19c841e567f26c34e77dbe254e530efacd6b3

onotices are displayed in the channel
omsgs are displayed in a query buffer as recommended

/notice has been implemented. /notice needs always a target as the first param. i.e. "/notice hi there" will send a notice "there" to user "hi".

#2 Updated by TerrorBite over 6 years ago

Reposting my previous comment properly because the formatting ate it:


Further to this I notice that when sending a notice to @#channel, the outgoing notice appears in the status window rather than the channel it's being addressed to. I'm guessing this is by design though as technically the target @#channel does not match #channel so shouldn't be directed there.

Thanks for displaying onotices in the channel though. Many other clients don't do this, and it renders the feature next to useless as they appear as private messages instead.

Also available in: Atom PDF