Project

General

Profile

Bug #1389

Rename a query buffer to contain a newline can lead to a crashing quasselclient

Added by public almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/01/2015
Due date:
% Done:

100%

Estimated time:
Version:
0.10.0
OS:
Windows

Description

Renaming a query buffer to contain a newline in the name can lead to a crash.

How to reproduce:
1. Rename a query buffer into a name that contains a newline (for example, using copy-paste of a multiline string)
2. Hover over buffername.

What should happen:
Tooltip is displayed normally

What does happen:
Client crashes.

Version: v0.12.2 (git-9c5e6c6) || Protocol version: 10 || Built: May 20 2015 14:17:35

Associated revisions

Revision ecf1ab29 (diff)
Added by Manuel Nickschas over 4 years ago

Don't allow newlines in buffer names

Since it is possible to enter newlines when renaming a buffer via
the GUI, we need to have a sanity check that cuts off the additional
lines.

Fixes #1389.

Revision 7bcfdef0 (diff)
Added by Manuel Nickschas over 4 years ago

Don't allow newlines in buffer names

Since it is possible to enter newlines when renaming a buffer via
the GUI, we need to have a sanity check that cuts off the additional
lines.

Fixes #1389.

History

#1 Updated by public almost 5 years ago

How to reproduce:
1. Rename a query buffer into a name that contains a newline (for example, using copy-paste of a multiline string)
2. Hover over buffername and clicking on it.

#2 Updated by Anonymous over 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF