Project

General

Profile

Bug #959

Bug in PostgreSQL migration

Added by amiconn over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Quassel Core
Target version:
Start date:
05/04/2010
Due date:
% Done:

100%

Estimated time:
Version:
0.6-pre
OS:
Any

Description

When migrating from SQLite to PostgreSQL, the 'joined' status of all buffers isn't migrated properly. They're all set to 'not joined'.

The problem is that the column IDs in sqlitestorage.cpp after 'buffer.markerlinemsgid' are off by one. Fix attached.

postgres-fix.diff (583 Bytes) postgres-fix.diff amiconn, 05/04/2010 02:52 AM
0001-Fix-959-SQLite-PostgreSQL-migration.patch (897 Bytes) 0001-Fix-959-SQLite-PostgreSQL-migration.patch amiconn, 05/04/2010 07:30 PM

Associated revisions

Revision aea18fce (diff)
Added by amiconn over 9 years ago

Fix #959: SQLite -> PostgreSQL migration

Revision 638ec016 (diff)
Added by amiconn over 9 years ago

Fix #959: SQLite -> PostgreSQL migration

History

#2 Updated by johu over 9 years ago

  • Status changed from New to Resolved
  • Assignee set to Sputnick
  • Target version set to 0.6.2
  • % Done changed from 0 to 100
  • Version changed from 0.4.3 to 0.6-pre

fixed with 638ec016

Also available in: Atom PDF