Project

General

Profile

Bug #926

per chat history odd behavior with /commands

Added by nirik almost 14 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
03/03/2010
Due date:
% Done:

90%

Estimated time:
Version:
0.6-pre
OS:
Any

Description

When enabling the per-chat history in 0.6.0rc1, I see an odd behavior.

Switch to a channel, type /me whatever.
It sends it to the channel as if it was quoted. Ie, you see "/me whatever" in the chanel litterally.

After that first time it seems to behave fine.

So, there seems to be a bug where it's not seeing /commands the first time you do something in a channel or when switching around.
I will try and see if there are any other cases. Thanks for implementing per-chat history! ;)

History

#1 Updated by nirik almost 14 years ago

Additionally, folks with other clients are reporting odd characters in my output:

16:51:31 nirik | ]ok, thats just bizzare. ]
16:53:46 nirik | ]huh? ]
16:54:40 nirik | ]ah ha. ]

it's putting ] ] around my output. ;(

#2 Updated by MarcLandis almost 14 years ago

  • Status changed from New to Feedback

I am not able to reproduce this. What build do you use and what OS?

#3 Updated by nirik almost 14 years ago

I'm using a self built rpm with Fedora 12.

It's using the 0.6.0-rc1 tar.gz

I can try and isolate it more today... perhaps it's related to another setting?

Will do some more testing and get back to you.

#4 Updated by johu almost 14 years ago

  • Assignee set to MarcLandis
  • Target version set to 0.6.0

#5 Updated by nirik almost 14 years ago

ok. More news here, just did some testing.

The core of the problem seems to be that I had a italic font set for my input widget, this causes it sometimes to send ] and confuse things.

To duplucate:

- Go to configure -> input widget -> custom font. Check the box and set it to a font thats 'italic' and apply.

- Go to a channel and type something, but don't hit return.

- Go to another channel and first thing type '/me actions' in input and hit return. I think it's sending ']/me actions]' For just that line. It then goes back to normal in that chat.

So, the workaround is: don't do bold/italic custom fonts in input.
But it seems like it's somehow picking that up after a change and sending it out.

Can you see it based on that?

#6 Updated by MarcLandis almost 14 years ago

  • Status changed from Feedback to Resolved
  • Target version changed from 0.6.0 to 0.7.0
  • % Done changed from 0 to 90

#7 Updated by MarcLandis almost 14 years ago

  • Target version changed from 0.7.0 to 0.6.0

Also available in: Atom PDF