Project

General

Profile

Bug #890

Blank query workaround not foolproof

Added by TerrorBite almost 12 years ago. Updated over 11 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/09/2010
Due date:
% Done:

0%

Estimated time:
Version:
0.5.0
OS:
Any

Description

Old bug: Server notices from say, irc.freenode.net would open a blank buffer even though the notices went to status.
This was not fixed but instead a workaround was implemented, by hiding the buffer from the chats list. The blank buffer is still created, and it opens when you click the glowing quassel tray icon to jump to the buffer with activity.
Since the buffer is hidden from the list, it cannot be closed.
Just pointing out that these blank buffers can still be accessed via the status icon, and that the cause of the bug should be fixed instead of the symptoms.

History

#1 Updated by EgS over 11 years ago

  • Status changed from New to Rejected

Actually that behavior is intended. You can easily (and now permanently) get rid of those buffers.

First to clarify: those buffers are more something like queries with an IRC node than like a status buffer, as the buffer contains notifies sent to you from a specific IRC node.

Those buffers are hidden, when you have message redirection enabled in such a manner, that "Server Notices -> Default Target" is disabled. To make those buffers visible, enablle that specific redirection setting and restart quassel. You can now see those buffers and delete them. Since the latest release the quassel core honors the redirection setting too and won't recreate the buffer if the default target is not enabled for server notices.

The reason why you can reach them via the status icon is due the fact that highlighting currently doesn't seem to respect message redirection. Which needs to be fixed.

And as a note: separate buffers for server notices can be handy for irc admins so it will not be forcibly deactivated.

Also available in: Atom PDF