Project

General

Profile

Bug #754

Initial backlog fetch causes a timeout while PostgreSQL uses a massive amount of CPU

Added by sph over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
07/28/2009
Due date:
% Done:

0%

Estimated time:
Version:
0.5-pre
OS:
Any

Description

After updating the core to v0.5-pre (0.4.0+205 git-4eba801), it no longer responds when a client is fetching the backlog. Meanwhile, the PostgreSQL db is using a massive amount of CPU.

A fresh start:

  PID USERNAME    THR PRI NICE   SIZE    RES STATE    TIME   WCPU COMMAND
 3061 pgsql         1   4    0   275M 10652K sbwait   0:00  0.39% postgres

Client fetches initial backlog:

  PID USERNAME    THR PRI NICE   SIZE    RES STATE    TIME   WCPU COMMAND
 3061 pgsql         1 112    0   275M   142M RUN      1:00 70.75% postgres

The client never receives any backlog and disconnects while complaining about the heartbeat, making Quassel completely useless for me :(

History

#1 Updated by honk over 10 years ago

Hello,
please check if this is a duplicate of #680.

#2 Updated by sph over 10 years ago

It is after #680 was fixed, but it's probably related.

#3 Updated by honk over 10 years ago

#680 was not fixed for everyone and in all circumstances by EgS's patch. Please check if it this is a duplicate of the bug.

#4 Updated by sph over 10 years ago

  • Status changed from New to Resolved

Yep, it was a duplicate. Upgrading to PostgreSQL 8.4 solved it.

Also available in: Atom PDF