Project

General

Profile

Bug #715

Never generate a Buffer with a comma

Added by valuial over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Quassel Core
Target version:
Start date:
06/04/2009
Due date:
% Done:

0%

Estimated time:
Version:
0.4.2
OS:
Any

Description

The comma separator in the recipient list of some messages is not evaluated correctly, or intuitivly.
For example:

euIRC, unlike freenode, supports sending NOTICE messages to multiple recipients as in rfc2812 (see post scriptum). But quassel creates a buffer with the name of the complete list, instead of adding the message to each buffer individually:

/notice target1,target2 message with spaces

is correctly translated into irc-protocol

NOTICE target1,target2 :message with spaces

but the buffer "target1,target2" is created, which should not happen.
For PRIVMSG I could not reproduce this erroneus behaviour - differend code here?

PS: on a sidenote: Freenode breaks rfc not accepting multiple recipients (nicks) in a PRIVMSG as defined in rfc1459 4.4.1 "Private Messages" and both PRIVMSG and NOTICE in rfc2815 2.3.1 (see description of msgtarget) used again in 3.3.1 Private Messages and 3.3.2 Notices.

History

#1 Updated by EgS over 10 years ago

  • Status changed from New to Confirmed
  • Assignee set to EgS

Confirmed.

Both PRIVMSG and NOTICE (and only those 2) can have multiple targets.

msgtarget  =  msgto *( "," msgto )
msgto      =  channel / ( user [ "%" host ] "@" servername )

#2 Updated by EgS over 10 years ago

  • Status changed from Confirmed to Resolved
  • Target version set to 0.4.3

Also available in: Atom PDF