Project

General

Profile

Bug #566

Segfault on network disconnect

Added by hxal over 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Quassel GUI (Qt)
Target version:
-
Start date:
02/18/2009
Due date:
% Done:

0%

Estimated time:
Version:
0.3.0.x
OS:
Linux

Description

I didn't try to reproduce it.

Here's what I did:
  • changed a server's connection options while being connected (port and SSL option)
  • disconnected from that network using the context menu in the buffer view
  • BAM

Distro: gentoo x86
Quasselclient version: 0.4.0 x86
Quasselcore version: 0.3.1-g734d4c9 amd64
Qt version: 4.4.2
CXXFLAGS=-O2 -ggdb -march=prescott -pipe -fno-omit-frame-pointer -mfpmath=sse -fvisibility-inlines-hidden

Automatic stacktrace attached.

quassel.trace (6.75 KB) quassel.trace hxal, 02/18/2009 02:56 AM
Quassel-Crash-20090218-2025.log (4.14 KB) Quassel-Crash-20090218-2025.log Sputnick, 04/02/2009 12:46 PM
Quassel-Crash-20090311-1834.log (4.87 KB) Quassel-Crash-20090311-1834.log Sputnick, 04/02/2009 12:46 PM
Quassel-Crash-20090311-0756.log (2.55 KB) Quassel-Crash-20090311-0756.log Sputnick, 04/02/2009 12:46 PM
Quassel-Crash-20090317-2137.log (4.87 KB) Quassel-Crash-20090317-2137.log Sputnick, 04/02/2009 12:46 PM

Related issues

Related to Quassel IRC - Bug #663: Crash when disabling uniform row heights for BufferViewAssigned2009-04-07

Has duplicate Quassel IRC - Bug #524: Crash while switching channelClosed2009-02-07

History

#1 Updated by Sputnick over 12 years ago

This trace shows up in some varieties, according to user feedback also sometimes triggered by temporarily hiding multiple buffers, or by selecting Connect or Disconnect from the network context menu. Seems to be related by Qt trying to repaint/resize the BufferView in a bad moment. More traces pointing to most probably that same issue attached.

#2 Updated by Sputnick over 12 years ago

  • Target version set to 0.4.2
  • Version changed from 0.4.0+ to 0.3.0.x

Bug #663 contains a) a real usable backtrace and b) a way that allows me to reproduce now :)

#3 Updated by Sputnick over 12 years ago

  • Target version changed from 0.4.2 to 0.4.3

#4 Updated by Sputnick about 12 years ago

  • Target version deleted (0.4.3)

#5 Updated by johu over 11 years ago

  • Status changed from Confirmed to Feedback

please give feedback, if this is resolved with quassel 0.5.2 or higher

#6 Updated by johu about 11 years ago

  • Status changed from Feedback to Closed

No feedback was given within 5 months.

Also available in: Atom PDF