Project

General

Profile

Bug #495

storage location of quasselclient.conf is not configurable

Added by billie over 13 years ago. Updated over 13 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Quassel Client
Target version:
Start date:
01/21/2009
Due date:
% Done:

80%

Estimated time:
Version:
0.3.1+
OS:
Any

Description

After changing the default location for configuration files quasselcore.conf successfully migrated to the customized --configdir. quasselclient.conf always stays at the new default location ~/.config/quassel-irc.org regardless of the --configdir setting.

History

#1 Updated by Sputnick over 13 years ago

  • Status changed from New to Feedback
  • Target version set to 0.4.0
  • % Done changed from 0 to 80

Works for me:

sputnick@axion tbuild % ./quassel --configdir=~/tmp/fubar

*** IMPORTANT: Config and data file locations have changed. Attempting to auto-migrate your client settings...
*   Your client settings have been migrated to "/home/sputnick/tmp/fubar/quasselclient.conf" 
*** Migration completed.

2009-01-22 20:32:06 Warning: SslServer: Certificate file /home/sputnick/tmp/fubar/quasselCert.pem does not exist
2009-01-22 20:32:06 Warning: SslServer: Unable to set certificate file
           Quassel Core will still work, but cannot provide SSL for client connections.
           Please see http://quassel-irc.org/faq/cert to learn how to enable SSL support.
2009-01-22 20:32:06 Warning: SslServer: Certificate file /home/sputnick/tmp/fubar/quasselCert.pem does not exist

*** IMPORTANT: Config and data file locations have changed. Attempting to auto-migrate your core settings...
*   Your core settings have been migrated to "/home/sputnick/tmp/fubar/quasselcore.conf" 
*   Your database has been moved to "/home/sputnick/tmp/fubar/quassel-storage.sqlite" 
*** Migration completed.

2009-01-22 20:32:06 Info: Storage Backend is ready. Quassel Schema Version: 13
2009-01-22 20:32:06 Info: Restoring previous core state...
sputnick@axion tbuild % ls ~/tmp/fubar
quasselclient.conf  quasselcore.conf  quassel-storage.sqlite
sputnick@axion tbuild %

Please try again and make sure you did nothing wrong; if it still fails, please describe exactly what you did. Migration code for core and client settings is identically, and they both use Quassel::configDirPath() to determine the new files' location, so I don't see how this could fail, and I obviously can't reproduce.

#2 Updated by billie over 13 years ago

1. Stop core
2. Move files (quasselCert.pem quasselclient.conf quasselcore.conf quassel-storage.sqlite) to /tmp/fubar
3. Start core with "quasselore --configdir=
/tmp/fubar"
4. All files are recognized in the location for configdir passed to quasselcore besides quasselclient.conf which is ignored and created at ~/.config/quassel-irc.org
5. Getting almost kick-banned on a few channels after doing this ten times within 15 minutes ;-)

#3 Updated by Sputnick over 13 years ago

Can you tell me what's in that file that gets created? I have a feeling that it's quite empty...

#4 Updated by Sputnick over 13 years ago

  • Status changed from Feedback to Rejected

Error on layer 8.

Also available in: Atom PDF