Project

General

Profile

Bug #492

Dropdown nick selector does not follow actual nick

Added by billie about 13 years ago. Updated almost 13 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Quassel Client
Target version:
Start date:
01/20/2009
Due date:
02/16/2009
% Done:

0%

Estimated time:
Version:
0.3.1+
OS:
Any

Description

When changing the nick with the /nick command the selector does not switch to the new nickname. This also happens after a network disconnect when quassel switches to an alternative nickname because the old nick has not reached it's timeout.

History

#1 Updated by EgS almost 13 years ago

  • Due date set to 02/16/2009
  • Assignee set to EgS
  • Target version set to 0.4.0

#2 Updated by EgS almost 13 years ago

  • Status changed from New to Feedback

I just tried to reproduce the issue.
Nick changes triggered by "/nick newNick" were correctly reflected in the nickselector regardless of newNick being a known Nick (in the Identity) or a random one.

This was probably fixed in:
http://git.quassel-irc.org/?p=quassel.git;a=commitdiff;h=8056d708179608e637f351e975dcc4efe01247d1

Please retest with current git.

#3 Updated by amiconn almost 13 years ago

Issue is 100% reproducable with Windows client 0.3.1 [+234]. Several earlier Windows versions had it too, but it used to work in December 2008.

Issue is not reproducable on Linux, neither with [+220] nor with [+261].

Test with current git is not possible on Windows, as there are no builds available. There seem to be build problems on Windows due to http://git.quassel-irc.org/?p=quassel.git;a=commit;h=36b30b6b8775f5322fad3d1ee99545a07baf9e20

#4 Updated by EgS almost 13 years ago

amiconn did some more intensive testing with newer and different windows builds and wasn't able to reproduce the issue since.
I don't have a good feeling about this, so this is still open for feedback.

#5 Updated by billie almost 13 years ago

I pretty much run git head most of the time. Will do some further testing this evening!

#6 Updated by EgS almost 13 years ago

billie reported on IRC that he wasn't able to reproduce the issue anymore. I'm leaving the report open for a couple of days in case someone comes up with anything new.

#7 Updated by EgS almost 13 years ago

  • Status changed from Feedback to Rejected

As nobody was able to reproduce this issue. I'm closing this report.

Also available in: Atom PDF