Project

General

Profile

Feature #337

Please add some sort of netsplit detection to stop the WALL OF TEXT

Added by TerrorBite about 13 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Quassel Core
Target version:
-
Start date:
Due date:
% Done:

90%

Estimated time:
OS:
Any

Description

Thanks!

History

#1 Updated by EgS about 13 years ago

Detecting a netsplit is somewhat easy... what is difficult is:

when a netsplit occurs the server sends one quit message per user. We would have to buffer those messages until the last one is sent, so we can remove the users as a bulk. The question is: which one is the last quit message?

#2 Updated by LucidFox over 12 years ago

I concur. You could probably look at the way netsplit detection is implemented in irssi.

#3 Updated by Sputnick over 12 years ago

  • Status changed from New to Confirmed

Question is we need to bulk-remove the users, or if just not showing the messages is already enough to fix the performance issue. To detect the end of it, one could probably just use a timeout (a second or so should be enough, since I assume that the QUIT msgs are sent en-block by the server) and then send a summary message to inform the GUI.

#4 Updated by seezer about 12 years ago

  • Assignee set to seezer

#5 Updated by seezer about 12 years ago

  • % Done changed from 0 to 90

Coreside work is done. For the clientside representation, I'll wait for the new fancy styling stuff to be merged into master. So you'll get pretty raw messages - but only one join/quit for each netsplit.

Work is done in my netsplit branch available at:
http://git.roath.org/?p=quassel.git;a=shortlog;h=refs/heads/netsplit

Note that the branch will be rebased after Sput's styling magic hit master.

#6 Updated by johu over 11 years ago

is this done? if yes, assign to specific version and mark as resolved, please.

#7 Updated by seezer over 11 years ago

  • Status changed from Confirmed to Resolved

As of fd80315c076ede937f5d51ba6f8061a32d0107ec we have netsplit handling - even though it will see a major rewrite in the future...

Also available in: Atom PDF