Project

General

Profile

Bug #1616

Quassel client is using a path to xdg-open that no longer exists

Added by pkill9 8 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
11/02/2020
Due date:
% Done:

0%

Estimated time:
Version:
0.13.0
OS:
Linux

Description

As a result links cannot be opened.

I cannot find where quassel client stores the path to xdg-open.

History

#1 Updated by pkill9 4 months ago

<removed> wrote:

<removed quoted spam comment>

Hi, thanks for responding, I found out the cause recently and it is caused by the package of QT that my distro (Guix System) uses, specifically it is patched to point to a hardcoded xdg-utils/bin/xdg-open (http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/qt.scm#n545) which isn't guaranteed to be there because it isn't protected from garbage collection, so isn't something that Quassel needs to fix.

#2 Updated by genius3000 4 months ago

  • Status changed from New to Closed

Closing as per the above reply from OP. Thanks!

Also available in: Atom PDF