Project

General

Profile

Bug #1485

Receiving a new message causes the topic editor to deselect and lose changes

Added by rubenwardy almost 3 years ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Quassel Client
Target version:
Start date:
06/24/2018
Due date:
% Done:

100%

Estimated time:
Version:
0.12.4
OS:
Any

Description

I'm using quassel v0.13-pre (0.12.0+690 git-cb63e88d)
The core uses 1:0.13.0~alpha+201806212016-0ubuntu0~built201806220131~gitda1a6f4~ubuntu18.04.1

Associated revisions

Revision b0035602 (diff)
Added by Lee Starnes 7 months ago

qtui: Keep editing topic while someone talks

Without this change, it's almost impossible to edit the topic with the
topic widget in busy channels because every message would trigger the
dataChanged signal which would reset the topic and switch the topic
widget out of editing mode.

Fixes #1485.

History

#1 Updated by rubenwardy almost 3 years ago

Client OS: Manjaro XFCE
Server OS: Ubuntu 18.04

To reproduce: try editing the topic using the GUI at the top in a busy channel, it'll close and go back to the non-editing mode, losing and progress

#2 Updated by Anonymous 7 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF