Project

General

Profile

Bug #1471

Show channels dialog (/list ui) overflows

Added by gry over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/26/2018
Due date:
% Done:

100%

Estimated time:
Version:
0.12.4
OS:
Any

Description

Show channels dialog (/list ui) overflows at freenode and gamesurge. After populating the dialog a little Quassel starts showing /list in the network chat view instead. Perhaps this is because /list is large, or the network is sending something that Quassel takes for 'this is the end of /list' signal. Anyway, this needs to be investigated and fixed.

History

#1 Updated by gry over 2 years ago

Just to be clear: the steps to reproduce are "connect to freenode or gamesurge, right click the network name, click 'Show channel list', click 'show channels' in the dialog that opens. Expected is all channels are shown in the dialog. Actual result is that /list output starts flooding the network chat view in raw form.

#2 Updated by genius3000 over 2 years ago

I'm quite certain this is due to a command timeout timer being hit while the server is still replying. That causes the current channel list to show in the UI and report as finished, therefore the rest of the list goes to the status buffer.
Increasing the timer duration or even the as is implementation, can be problematic with multiple clients or when requesting a channel list more than once (accidentally clicking again, different networks).
As noted on IRC by justJanne, this is only fully fixable once the IRCv3 batch and label caps are standard.
I'm hoping to find a solution to at least better the current method and minimize the chance of issues with the channel list.

#3 Updated by genius3000 almost 2 years ago

  • Status changed from New to Resolved
  • Assignee set to genius3000
  • % Done changed from 0 to 100

#4 Updated by genius3000 almost 2 years ago

  • Target version set to 0.13.0

Also available in: Atom PDF