Project

General

Profile

Bug #1308

Quassle 0.10 does not contain crypto plugins folder. Fails to auth with /setkey

Added by the7thcolumn over 3 years ago.

Status:
New
Priority:
High
Assignee:
-
Category:
General / Unspecified
Target version:
Start date:
09/03/2014
Due date:
% Done:

0%

Version:
0.10.0
OS:
Windows

Description

First bug report bear with me.

Issue does not occur in 0.9.1 - Windows 8.1 x64
Issue occurs in 0.10 - Windows 8.1 x64

When attempting to type in /setkey I recieve the following error:

  • Error: Setting an encryption key requires Quassel to have been built with support for the Qt Cryptographic Architecture (QCA) library. Contact your distributor about a Quassel package with QCA support, or rebuild Quassel with QCA present.

Expected result is that it would auth. with the channel or with the user.

This can be fixed by copying a 0.9.1 install on top of 10 replacing all files (obviously). I also noticed in 0.10 C:\Program Files (x86)\Quassel\plugins\crypto is missing.

Also available in: Atom PDF