Project

General

Profile

Bug #1233

Language changed after upgrade

Added by nasso over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
Start date:
06/26/2013
Due date:
% Done:

100%

Estimated time:
Version:
0.9-pre
OS:
Mac OS X

Description

I just upgraded quassel to the following version:

Version: v0.9.0 (git-3b9dd10*)
Protocol version: 10
Built: May 9 2013 12:48:26

I downloaded the dmg-file. Mounted it and dragged the application to the applications folder. I clicked on replace to replace the old version.

When i started up quassel everything in the ui was in japanese/chinese or something like that.

I have no idea how to change it back to english, as i dont know japanese.

The preferences item in the menu is still in english. And the reset defaults button is too.
If i reset defaults, will all my connections/irc server configurations be removed?

Can someone guide me in the interface to the place where is can change the language?

Also, the version i use is not available in the versions selectbox. Im using 0.9 not 0.9-pre.

Associated revisions

Revision 7a3f6201 (diff)
Added by Bas Pape over 6 years ago

Use the old way of finding translations for OSX.

Many OSX users reported their clients being in Japanese, rather than
English, since 0.9.0, which turned out to be due to
QSystemLocale::query for QSystemLocal::UILanguages (internally done by
Qt if a QLocale is passed to QTranslator::load) returning 'en', rather
than the proper local form (e.g. 'en-US').
As 'en' has no translation, the second language got picked up, which
happened to be 'ja', which does have a translation.

Fixes #1233 (but reintroduces #1194 on OSX)

Revision 20e3307b (diff)
Added by Bas Pape over 6 years ago

Use the old way of finding translations for OSX.

Many OSX users reported their clients being in Japanese, rather than
English, since 0.9.0, which turned out to be due to
QSystemLocale::query for QSystemLocal::UILanguages (internally done by
Qt if a QLocale is passed to QTranslator::load) returning 'en', rather
than the proper local form (e.g. 'en-US').
As 'en' has no translation, the second language got picked up, which
happened to be 'ja', which does have a translation.

Fixes #1233 (but reintroduces #1194 on OSX)

History

#1 Updated by Anonymous over 6 years ago

  • Status changed from New to Confirmed
  • Priority changed from Normal to Urgent

Go to settings, set the second dropdown to the first value and after restarting the client, you should end up with an untranslated (thus english) client.

#2 Updated by Anonymous over 6 years ago

  • Target version set to Some future release

#3 Updated by Anonymous over 6 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Applied in changeset quassel|commit:20e3307b37c03c22b97c060fd2dc0c999f0219b6.

Also available in: Atom PDF