Project

General

Profile

Bug #1197

Quassel completely drops lines that contain only spaces instead of displaying them

Added by rikai about 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Quassel Core
Target version:
Start date:
12/02/2012
Due date:
% Done:

100%

Estimated time:
Version:
0.3.0.x
OS:
Any

Description

Simple one to reproduce.

Any messages that are all spaces are not shown at all on Quassel but are on other clients.

The same lines are displayed, though they are oddly split into multiple messages when they are. Probably a separate bug?

xchat.png (78.4 KB) xchat.png XChat 2.8.8 linux displaying the lines properly. rikai, 12/02/2012 10:07 PM
quassel.png (109 KB) quassel.png Showing Quassel dropping the same lines with no indication they were ever received. rikai, 12/02/2012 10:07 PM
SentText.png (5.35 KB) SentText.png Same line sent from Quassel client showing the single line being split into multiples. Tucos suggests this is likely do to word wrapping, so may not be related. rikai, 12/02/2012 10:07 PM

Associated revisions

Revision b426e534 (diff)
Added by Bas Pape about 7 years ago

Only chop \r\n instead of trimming all whitespace

Any whitespace in front of the protocol's \r\n is part of the message
and thus should not be trimmed. Fixes #1197

History

#1 Updated by Anonymous about 7 years ago

  • Category set to Quassel Core
  • Assignee set to Anonymous
  • Target version set to Some future release

#2 Updated by Anonymous about 7 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#3 Updated by Anonymous almost 7 years ago

  • Target version changed from Some future release to 0.9.0
  • Version changed from 0.8-pre to 0.3.0.x

Apparently causes some subtle issues because other parts of quassel expect trimmed output and ircds are silly.

Also available in: Atom PDF