Project

General

Profile

Bug #113

/topic without parameter should display the topic

Added by phon over 12 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Quassel Core
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Version:
0.13.0
OS:
Any

Description

example from weechat:
[12:37:19] =- Das Topic von #quassel lautet: "Quassel IRC || ALL NEW http://quassel-irc.org || Bugs and Feature Requests: http://bugs.quassel-irc.org || Warning: r570+ core crashes on exit!" ?
[12:37:19] -=
Topic gesetzt von EqS, Fri Feb 22 00:03:51 2008

Associated revisions

Revision 31cf429f (diff)
Added by Manuel Nickschas over 11 years ago

Display rather than clear the channel topic on /topic without params

This has been discussed in BR #113 as well as #BR 289. User feedback has shown that
this is the expected behavior, moreover users have complained about accidentally clearing
the topic.
This requires a core restart.

History

#1 Updated by EgS about 12 years ago

We have a pretty nice gui and don't need to rely on such crude features... -> won't fix

#2 Updated by Sputnick over 11 years ago

Since several users have complained about clearing the topic accidentally, and param-less /topic indeed displays the topic in most clients (and never clears it), I have changed the behavior.

http://git.quassel-irc.org/?p=quassel.git;a=commit;h=31cf429ff1ffbc1cf1dea04935744f0ce0fb9829

Also available in: Atom PDF