Project

General

Profile

Bug #1093

Quassel intermittently forgets settings

Added by letharion over 7 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Quassel Client
Target version:
-
Start date:
08/30/2011
Due date:
% Done:

100%

Estimated time:
Version:
0.7.2
OS:
Linux

Description

Every now and then, when I start Quassel up, all settings are missing.
I need to re-create my highlight settings, add the server ip, and such.

It looks like the quasselclient.conf file just goes missing and a new one is created with default settings.

Gentoo Linux, KDE 4.7.0.

History

#1 Updated by letharion over 7 years ago

I could possibly be related to forcing Quassel to close with "systemctl --force reboot", rather than closing Quassel itself first. Not sure about this though.
Still intermittently happens in KDE 4.7.3 and with Quassel 0.7.3.
I would update the version number on the issue, but I'm not really familiar enough with redmine, I can't seem to figure out how to do it.

#2 Updated by letharion almost 7 years ago

Still happens on Quassel 8.0 and kde 4.8.3.

#3 Updated by realitygaps almost 5 years ago

Still seems to happen with Quassel 0.9.2 and KDE 4.12.4

#4 Updated by LongHairedHacker almost 5 years ago

Hi,

I have the same issue on Archlinux with Quassel (client only setup) 0.9.2 dist-748fa5c.
This bug is not related to the desktop environment use, it affects me when I'm using xfce4 as well as when I'm using i3.
I also encountered this bug under Debian wheezy on powerpc with Quassel 0.8.0.

It seems as if the config file gets reset to defaults a soon as Quassel is killed with sigterm instead of exited properly.

#5 Updated by ypcs over 4 years ago

Bug still exists. This happens ~every third time when I shutdown the system from CLI, using "shutdown -h now".

Quassel IRC v0.10.0 (dist-575f27e) on Debian testing (8/jessie), with XFCE4/LightDM. SystemD as init.

#6 Updated by davispuh over 4 years ago

Happened to me for 2nd time now with latest Quassel

Qt: 4.8.6
KDE izstrādes platforma: 4.14.1
Quassel IRC: v0.10.0 (dist-575f27e)

I noticed that both times it could have been caused by full /var partition but still weird that it overwrote config.

#7 Updated by davispuh over 4 years ago

davispuh wrote:

Happened to me for 2nd time now with latest Quassel

Qt: 4.8.6
KDE izstrādes platforma: 4.14.1
Quassel IRC: v0.10.0 (dist-575f27e)

I noticed that both times it could have been caused by full /var partition but still weird that it overwrote config.

or mabye it was becuase /home partition was full too

#8 Updated by reazem almost 4 years ago

I have the same issue.

I am using v0.10.0 (dist-575f27e)

#9 Updated by flamingspinach almost 4 years ago

This might have been a bug in Qt which is now fixed as of Qt 5.4.0: https://bugreports.qt.io/browse/QTBUG-21739

Can anyone replicate this on Quassel v0.11 linked against Qt 5.4.0 or newer?

#10 Updated by flamingspinach over 3 years ago

flamingspinach wrote:

This might have been a bug in Qt which is now fixed as of Qt 5.4.0: https://bugreports.qt.io/browse/QTBUG-21739

Can anyone replicate this on Quassel v0.11 linked against Qt 5.4.0 or newer?

FWIW I've been using Quassel built with Qt5 since I made that comment and have never encountered this issue, despite encountering it many times before that.

#11 Updated by Sputnick 3 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

This was an issue in Qt 4 that has been fixed a long time ago, as confirmed by flamingspinach, so closing this.

Also available in: Atom PDF