Project

General

Profile

Bug #483

RIght click opens new browser(tab)

Added by pennywise over 12 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Quassel Client
Target version:
Start date:
01/14/2009
Due date:
% Done:

100%

Estimated time:
Version:
0.3.1+
OS:
Any

Description

I know someone mentioned this in #quassel, but I didn't found a corresponding bug. So forgive me if it's a duplicate.

When you're in a channel and someone paste a link, you can simply click on it to go to that webpage. But on my git-quassel (0.3.1 +215 http://git.quassel-irc.org/?p=quassel.git;a=commit;h=12088be1ee7c16faf52a39ab2b6e01a6ec7bfeb6) after clicking on that link, going back to quassel, rightclick somewhere in the chatbuffer, the page opens again (and again if you rightclick again). This does not happen, if you didn't click a link in that channel.

So, here are the steps to reproduce
1) click on an url
2) go back to quassel (cause browser is stealing focus)
3) right click into chatbuffer

History

#1 Updated by pennywise over 12 years ago

Addionally info:

the context menu which is brought to you by the right click is now "on top" of the browser. If you actually choose something in that context menu than that right click bug is gone until you click again on an url.

#2 Updated by pennywise over 12 years ago

Ok, next hint:

1) Click on a link in quassel
2) switch focus back to quassel (I click on the windows taskbar)
3) the contextmenu is now on top of quassel (was on top of browser)
4a) If you press ESC you're fine
4b) If you left/rightclick on somewhere in the chatwindow (NOT on the contextmenu) the clicked link is opened again
4ba) If you keep rightclicking for each click a new tab is opened
4bb) If you leftclick (either choose something out of the contextmenu or click on quassel) you're good again

#3 Updated by Sputnick over 12 years ago

  • Status changed from New to Feedback
  • Assignee set to Sputnick

#4 Updated by pennywise over 12 years ago

looks good. can't reproduce it now. will try it tomorrow again at work, there was the client with the issue.

#5 Updated by Sputnick over 12 years ago

  • Status changed from Feedback to Closed
  • Target version set to 0.4.0
  • % Done changed from 0 to 100

Got feedback from several users that this commit indeed fixes the issue, so I'm closing this bug.

Also available in: Atom PDF