Project

General

Profile

Feature #455

Redesign the mono client's core connect dialog

Added by Sputnick about 14 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Usability
Target version:
Start date:
03/01/2009
Due date:
% Done:

0%

Estimated time:
OS:
Any

Description

For the mono client, we need to make the connection dialog more intuitive for users not familiar with Quassel's core/client concept. Seele's review as well as many user questions have proved that the current way of providing the standard core connect dlg and an additional "Use internal core" button are confusing.

For the mono client only, I would suggest offering a direct way to connect to IRC, either by selecting an existing network/identity, or, if none exists, a quick way of creating those (say, enter a server address and a nickname, and then create a default network/identity from that; possibly popup the standard config dialogs).

We could still offer using a remote core by a button "Connect to remote Quassel Core" or something; but that should be clearly visible as an advanced thing rather than the default action to do.

History

#1 Updated by EgS almost 14 years ago

  • Target version deleted (0.4.0)
  • Start date changed from 12/30/2008 to 03/01/2009

Removing 0.4.0 as Target Version, since that releases mono build won't feature a core connect dialog.

#2 Updated by johu almost 13 years ago

  • Status changed from Confirmed to Closed
  • Target version set to 0.4.0
  • OS set to Any

... so this can be closed

Also available in: Atom PDF