Project

General

Profile

Bug #289

/topic without parameters should display topic

Added by Daisuke_Ido almost 12 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
General / Unspecified
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Version:
0.13.0
OS:
Any

Description

I'm aware this was covered in http://bugs.quassel.info/view.php?id=113 and labeled wontfix.

What is the sense in taking a command that is firmly entrenched in nearly every, if not every, other IRC client released in the past fifteen years and replacing it with something that is actually destructive (clears the existing topic) if the user is not aware of this particular client's quirk regarding this command? Having /topic display the existing topic is, and has been, expected behaviour for quite a long time.

History

#1 Updated by webarnes almost 12 years ago

This is annoying. I've been using IRC for ten years and old habits are ingrained. Displaying the topic has always been the expected behaviour of '/topic'.

Would you change the behaviour of /part? Maybe make it disconnect you from the server? Probably not.

#2 Updated by Daisuke_Ido almost 12 years ago

Additionally, http://www.irchelp.org/irchelp/rfc/chapter4.html#c4_2_4 states that:

The TOPIC message is used to change <b>or view</b> the topic of a channel. The topic for channel <channel> is returned if there is no <topic> given. If the <topic> parameter is present, the topic for that channel will be changed, if the channel modes permit this action.

/topic alone changes the channel topic to a blank string (While not explicitly covered in the RFC, this does go against long-established behaviour)

/topic <channel> changes the topic to the channel name (against the RFC)

/topic <channel> <topic> changes the topic to the channel name followed by the topic (again, against the RFC)

#3 Updated by EgS almost 12 years ago

Um first of all: if there already is a bug covering this topic, then please stick to that one. This makes things less confusing for users searching the existing bugs. Yes, there is actually a way to reopen bugs.

second: webarnes, thanks for that very helpful comment...

third: rfc is about IRC as a protocol. there are many commands in quassel that are not a 1 to 1 mapping of raw IRC and believe me, you don't want that to be changed. Or would you want "/kick user you don't belong here" to try to kick the user "you" from channel "user" with the reason "don't belong here"? I guess not...

forth: I acknowledge that the default behaviour is not what old IRC die-hards might expect from an IRC client.

#4 Updated by Sputnick over 11 years ago

Since several users have complained about clearing the topic accidentally, and param-less /topic indeed displays the topic in most clients (and never clears it), I have changed the behavior.

http://git.quassel-irc.org/?p=quassel.git;a=commit;h=31cf429ff1ffbc1cf1dea04935744f0ce0fb9829

Also available in: Atom PDF