Project

General

Profile

Bug #235

Filtering to "New Messages" also is triggered by "other activity"

Added by ZRegis almost 13 years ago. Updated over 12 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Quassel Core
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Version:
0.13.0
OS:
Any

Description

Each user auto mode by a bot mark the chan as a new message:

Ex:
[10:13:59] *** Mode #amo +v Archaeopteryx par ChanServ

Decrease activity for 'Mode change' to 'another Activity' type.

To prevent wrong hightlight of chan

History

#1 Updated by EgS almost 13 years ago

mode changes don't increase the activity level to "new message".

from the sources:

ActivityLevel level = activityLevel() | OtherActivity;
if(msg.type() & (Message::Plain | Message::Notice | Message::Action))
level |= NewMessage;

I also was not able to reprduce the effect.

#2 Updated by ZRegis almost 13 years ago

My settings are Minimal Activity: New Message:

so how can this can select the chan every Mode ?

[01:14:22] --> fligtar () a rejoint #addons
[01:14:22] *** Mode #addons +o fligtar par ChanServ
[01:17:50] <-- stephend () a quitté (Quit: stephend)

(edited by EgS: chopped for readability)

#3 Updated by EgS almost 13 years ago

Thanks for the feedback. This is a whole different thing.
I changed the subject to the BR to reflect the issue. I will look into it this weekend.

#4 Updated by EgS almost 13 years ago

hmm... even that I couldn't reproduce...
could you please attach a screenshot to this bugreport? Please make sure, that it's one screenshot where the following stuff is visible:
1) the buffer view with the channel having a activity level lower then "new message"
2) the buffer view settings page with the config of that particular buffer view being shown.

#5 Updated by EgS over 12 years ago

as I've heard nothing new in this issue, I'm marking this as unable to reproduce

Also available in: Atom PDF