Project

General

Profile

Bug #1539

Notifications not shown nor sounded in Linux Mint 19.2

Added by ad5xj about 2 years ago. Updated 7 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/22/2019
Due date:
% Done:

0%

Estimated time:
Version:
0.13.0
OS:
Any

Description

Settings configured to issue a sound and a message on notifications. however neither happen. I do get sound and messages on other applications (like Pidgin).

History

#1 Updated by sudoman almost 2 years ago

I'm not getting any notifications from Quassel client 0.13.1 or the master branch on Debian 10 (with GNOME Shell). I'm currently using version 0.13.0 of Quassel core.

Thanks : )

#2 Updated by sudoman almost 2 years ago

I should mention that I have seen occasional flashing icon alerts on either Debian 10 or Trisquel 9 (Based on Ubuntu 18.04). So this might be working some of the time for some distros. I'm using Wayland on both. Thanks : )

#3 Updated by ricab almost 2 years ago

Notifications failing most of the time here too, on Ubuntu 19.10. A couple of other people confirmed they saw the same (one of them on the 20.04 dev version, I don't know about the other).

#4 Updated by sudoman almost 2 years ago

I should also mention that I'm using https://extensions.gnome.org/extension/615/appindicator-support/ in Gnome shell on my Debian 10 machine.

#5 Updated by sudoman over 1 year ago

Thanks for Quassel. It's a really great IRC client, even with this one bug that I ran into. : )

I'm using Gnome and Wayland on Debian 10. I also run Quasseldroid 1.2.23 on my phone.

Using Quassel Client 0.13.1 from Debian repos, and custom builds of master, I originally wasn't getting notifications. However when I ran either version from the command line, I would get notifications, but not otherwise. I decided to comment out the 'X-DBUS-ServiceName=org.quassel-irc.quasselclient' line in qusselclient.desktop, and I'm pretty sure that launching the application from the Gnome GUI worked. However when i put that line back, notifications started working regardless of how I try to launch Quassel.

I tried leaving everything installed in /usr/local/, removing just the binaries, and removing everything related to Qassel under /usr/local/. The version from Debian works regardless.

I also experimented with this on Trisquel 9 (based on Ubuntu 18.04) and Gnome / Wayland. I got notifications to work occasionally with version 0.13.1 and the help of the "The Kstatusnotifieritem/appindicator support" plugin, but in the end, I wasn't able to get notifications to work at all on that machine, even if Quassel Client wasn't running on the Debian machine. Occasionally the version on Debian didn't work, possibly related to the behavior of the Trisquel machine, but for the most part, it works in Debian.

Thanks again : )

Also available in: Atom PDF