Project

General

Profile

Bug #1404

Core crashes with error about locked database when creating a new network

Added by wrtlprnft almost 8 years ago. Updated over 7 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Quassel Core
Target version:
-
Start date:
04/07/2016
Due date:
% Done:

0%

Estimated time:
Version:
0.3.0.x
OS:
Any

Description

I don't know exactly how to reproduce this bug, but my quasselcore crashed when a user tried to create a network. Here's the log (I didn't have debug messages enabled at the time):

22176 2016-04-06 22:54:53 Error: unhandled Error in QSqlQuery!
22177 2016-04-06 22:54:53 Error:                   last Query: INSERT INTO buffer (userid, networkid, buffername, buffercname, buffertype, joined)VALUES (:userid, :networkid, :buffername, :buffercname, :buffertype, :joined)
22178 2016-04-06 22:54:53 Error:               executed Query: INSERT INTO buffer (userid, networkid, buffername, buffercname, buffertype, joined)VALUES (?, ?, ?, ?, ?, ?)
22179 2016-04-06 22:54:53 Error:                 bound Values: :buffercname='', :buffername='', :buffertype=1, :joined=0, :networkid=12, :userid=2
22180 2016-04-06 22:54:53 Error:                 Error Number: 5
22181 2016-04-06 22:54:53 Error:                Error Message: database is locked Unable to fetch row
22182 2016-04-06 22:54:53 Error:               Driver Message: Unable to fetch row
22183 2016-04-06 22:54:53 Error:                   DB Message: database is locked
22184 2016-04-06 22:54:53 Error: ASSERT: "!createBuffer" in file /var/tmp/portage/net-irc/quassel-0.12.2-r4/work/quassel-0.12.2/src/core/coresession.cpp, line 323

After the crash, the assignment between identities and networks was messed up in my account (not the one that presumably caused the crash). I had two identities, with one only in use by one network, and that assignment "shifted" after the crash. It wasn't critical in my case, but this could be quite annoying or embarassing.

Also, the Version field in this bug tracker doesn't allow me to select my version of quassel, so that field contains garbage.

History

#1 Updated by YtvwlD almost 8 years ago

I might have encoutered the same issue. After adding a network my Core crashed immediately and crashes frequently and mostly won't come up.

I'm currently transferring my database to Postgres - perhaps that'll help.

#2 Updated by wrtlprnft almost 8 years ago

I should have mentioned that so far, I've exclusively used sqlite (version 3.12.0) with quassel.

#3 Updated by Robsdedude over 7 years ago

I've encountered the same issue as well. Core couldn't recover. All client side tries to connect resulted in a 'connection refused'. Nor further log messages after that crash. Restarting the core fixed it. Running version v0.12.4 (dist-90183ee) on Debian Jessie.

Also available in: Atom PDF