Project

General

Profile

Bug #123

"Mouse wheel changes displayed buffers" setting is not shown correctly

Added by EgS almost 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Quassel GUI (Qt)
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Version:
0.13.0
OS:
Any

Description

This option is always shown as "on" in the Settings dialog.

Setting it works properly, but it's somewhat tricky as you sometimes have to change some thing different to even be able to click "apply"...

History

#1 Updated by phon almost 12 years ago

unfortunately i cannot reproduce this bug.
it should be a problem with the load and save - but is looks just fine for me:

load:
UiSettings uiSettings("Ui");
settings["MouseWheelChangesBuffers"] = uiSettings.value("mouseWheelChangesBuffers", QVariant(true));
ui.mouseWheelChangesBuffers->setChecked(settings["MouseWheelChangesBuffers"].toBool());

save:
UiSettings uiSettings("Ui");
uiSettings.setValue("MouseWheelChangesBuffers", ui.mouseWheelChangesBuffers->isChecked());

#2 Updated by phon almost 12 years ago

wow - windows seems to be case-insensitive

Also available in: Atom PDF