Project

General

Profile

Bug #1063

n900 hildon style: UI stylesheet bugs (when custom colors are enabled)

Added by sgiessl almost 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Quassel2Go
Target version:
Start date:
03/12/2011
Due date:
% Done:

0%

Version:
0.7-pre
OS:
Any

Description

Steps to reproduce:
- Settings dialog: Enable custom colors

Effect:
- the maemo application menu has unusally large space between the items
- the chat text input line has wrong colors: black text on black background

History

#1 Updated by sgiessl almost 7 years ago

This bug is related to stylesheets and is most likely a bug in qt, because exactly the same happens for any qt app which happens to be using qt-stylesheets.
i.e. the bug happens even here:
qmlviewer -stylesheet /dev/null

http://www.forums.internettablettalk.com/showthread.php?p=878901 claims that this is a bug in Qt 4.7 (since n900 firmware version pr1.3)

#2 Updated by sgiessl over 6 years ago

  • Status changed from New to Resolved

worked around the bug by avoiding qt stylesheets by default and allowing custom stylesheets to modify the input line background color explicitly.

Also available in: Atom PDF