Project

General

Profile

Build Quassel on Windows Mingw

Build Quassel with QT only

Software Requirements

Installation

Install Python

If you already have installed python you can skip this step.

Install Git

If you already have installed python you can skip this step.

Setup your installation directory
Create the directory you will use as your ROOT directory for your quassel build.

Install and setup emerge

First of all you need to checkout emerge using git.
Open a powershell or instance, switch to your ROOT directory and clone emerge "git clone git://anongit.kde.org/emerge".
Check out the latest stable branch which is currently "kde-4.12"("cd emerge" "git checkout kde-4.12").
Create a "etc" folder in your ROOT directory.
Save the following ini file to "ROOT/etc/kdesettings.ini"

[General]
#a fast make tool for cmake projects
EMERGE_USE_NINJA = True
KDECOMPILER = mingw4
EMERGE_ARCHITECTURE = x86
EMERGE_VERBOSE = 1
EMERGE_NOCOPY = True
#use jom, jom is a fast make tool
EMERGE_MAKE_PROGRAM = jom
#use gcc 4.4.7
EMERGE_OPTIONS = features.legacyGCC=True

[Paths]
DOWNLOADDIR = ${KDEROOT}\download
KDEROOT = D:\quassel-noqt
PYTHONPATH = C:\python34
KDESVNDIR = ${DOWNLOADDIR}\svn
KDEGITDIR = ${DOWNLOADDIR}\git

[ShortPath]
EMERGE_USE_SHORT_PATH = False
EMERGE_ROOT_DRIVE = u:
EMERGE_SVN_DRIVE = s:
EMERGE_GIT_DRIVE = q:
EMERGE_DOWNLOAD_DRIVE = t:

[Version]
EMERGE_SETTINGS_VERSION = 1

[Portage]
PACKAGE_IGNORES =  win32libs/openssl;libs/qt;kde/kdelibs;kde/kde-runtime;kdesupport/phonon;kdesupport/phonon-ds9;binary/mysql-pkg;win32libs/dbus;dev-util/git;dev-util/subversion


Set KDEROOT to your ROOT directory for building quassel.
Set PYTHONPATH to the location of your python installation.

Important is the value of PACKAGE_IGNORES here we disable all packages emerge wants to install by default.

In your powersehll instance go to ROOT/emerge and call ". kdeenv.ps1" the "." is important to load the script.
If you get an error please try to set "Set-ExecutionPolicy RemoteSigned" to make it possible to run downloaded scripts.

Lets start with emerging the compiler, "emerge mingw-w32".
Now lets see what emerge wants to install, call "emerge -p quassel", if you see a package in the list of dependencies you don't want to install add it to PACKAGE_IGNORES.

Install Qt 4.8.5

Install to your ROOT directory.
When you get asked for the location of your mingw location set it to "ROOT/mingw" and ignore the warning.

Build quassel
Go to your powershell window, and enter "emerge quassel" now quassel and all dependencies for quassel should be automatically be build.

dbghelp-mingw.zip - dbghelp for mingw (.h/.a/.dll) (445 KB) avih, 02/22/2013 10:21 PM