Project

General

Profile

Bug #821

Hovering a multline topic resizes widget below

Added by bjorninge over 7 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
10/08/2009
Due date:
% Done:

100%

Version:
0.9.0
OS:
Any

Description

When hovering over a long topic, quassle expands that topic to multile lines. This makes the widget below the topic (which is chatmon, or the chat view if chatmon is disabled) resize, and in the process that widget will be automatically scrolled to the bottom.

Associated revisions

Revision 777799ec (diff)
Added by seezer almost 3 years ago

Don't scroll to bottom on resize

We're brave today..
Resizing the chatview (even unintentionally by hovering the topicline)
resulted in scrolling down the current view.
There might have been reasons.. i can't see them..

Fixes #821

Revision 7bfe3185
Added by al almost 3 years ago

Merge pull request #77 from seezer/bug821

Don't scroll to bottom unexpectedly.

Fixes #821

History

#1 Updated by Anonymous over 3 years ago

  • Status changed from New to Confirmed
  • Version changed from 0.5-pre to 0.9.0

Unfortunately this is due to the way Qt deals with dock widgets resizing and the chatscene not taking kindly to being resized.

#2 Updated by seezer almost 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Applied in changeset quassel|commit:777799ecd614503b20c0fc9d31223556ecc6078b.

Also available in: Atom PDF