Project

General

Profile

Bug #298

Quassel join channels when single-clicking the name in the bufferview

Added by adamtulinius almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Quassel GUI (Qt)
Target version:
Start date:
Due date:
% Done:

0%

Version:
0.12.4
OS:
Any

Description

After parting a channel, a normal click on the channel will make you join again (-- it should be a double-click).

Regression from .. eh.. sometime in the past :-)

Associated revisions

Revision 0a82bb8c (diff)
Added by Manuel Nickschas over 8 years ago

Don't join channels on single click in bufferviews on X11, fixes BR #298

History

#1 Updated by Sputnick over 8 years ago

AFAIR this was changed from doubleClicked() to activated() a while ago, because doubleClicked() fails on Mac. Apparently, activated() fails on X11 though.

We explicitly require a double click now again on X11, even though the docs for activated() suggest differently...

http://git.quassel-irc.org/?p=quassel.git;a=commit;h=0a82bb8c3fe72240b6fa03fd1018289465abf7f1

Also available in: Atom PDF