Project

General

Profile

Bug #1218

Channel's un-hidden status doesn't stay between client restarts

Added by Darky over 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Quassel Client
Target version:
-
Start date:
04/28/2013
Due date:
% Done:

100%

Version:
0.9-pre
OS:
Any

Description

To get this effect, you have to follow these steps:

1. Hide channel temporarily
2. Part channel
3. Join channel (it will now be visible again, at the bottom of that network's buffer list)
Optional: talk in the channel, get other people to talk, etc but the buffer must not be blue (new message(s)) when you proceed next
4. Quit the client
5. When you'll restart it, the channel will be temporarily hidden again

Associated revisions

Revision f5071c58 (diff)
Added by ramz almost 3 years ago

Retains Channel UnHiddens Status after client Restart.

Steps to Reproduce:
1. Hide channel temporarily
2. Part channel
3. Join channel (it will now be visible again, at the bottom of that network's buffer list)
Optional: talk in the channel, get other people to talk, etc but the buffer must not be blue (new message(s)) when you proceed next
4. Quit the client
5. When you'll restart it, the channel will be temporarily hidden again

Root Cause:
After step 3, we are not saving the bufferviewconfig synchronizable object right.

Fix:
Save the bufferviewconfig object correctly.

Fixes #1218.

Revision f83c60b2 (diff)
Added by ramz almost 3 years ago

Retains Channel UnHiddens Status after client Restart.

Steps to Reproduce:
1. Hide channel temporarily
2. Part channel
3. Join channel (it will now be visible again, at the bottom of that network's buffer list)
Optional: talk in the channel, get other people to talk, etc but the buffer must not be blue (new message(s)) when you proceed next
4. Quit the client
5. When you'll restart it, the channel will be temporarily hidden again

Root Cause:
After step 3, we are not saving the bufferviewconfig synchronizable object right.

Fix:
Save the bufferviewconfig object correctly.

Fixes #1218.

History

#1 Updated by DevUrandom over 4 years ago

I can confirm this problem using client version 0.8.0.

#2 Updated by ramz almost 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF